import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ "\\.(3gpp?\n"
+ " |a(vi|sf|iff?)\n"
+ " |fl(ac|v)\n"
+ " |m(4a|ov|3u|id|kv|p\\d+|pg\\d*|peg\\d*)\n"
+ " |ogg \n"
+ " |w(av|ebm|m[av])\n"
+ ")";
final String string = ".m4a .wav .ogg .flac .avi .flv .mov .m3u .mid .webm .mkv .asf\n\n"
+ ".mpg .mpeg .mp10 .mpg10 .mpeg13 \n\n"
+ ".aif AND .aiff\n\n"
+ ".3gp AND .3gpp\n\n"
+ ".wma AND .wmv\n"
+ "bla.mp3 bla bla.mid.mp3.mp4.mid.mp10.mpeg.mpg.mpg10\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}