const regex = /
\.(3gpp?
|a(vi|sf|iff?)
|fl(ac|v)
|m(4a|ov|3u|id|kv|p\d+|pg\d*|peg\d*)
|ogg
|w(av|ebm|m[av])
)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('
\\.(3gpp?
|a(vi|sf|iff?)
|fl(ac|v)
|m(4a|ov|3u|id|kv|p\\d+|pg\\d*|peg\\d*)
|ogg
|w(av|ebm|m[av])
)', 'ig')
const str = `.m4a .wav .ogg .flac .avi .flv .mov .m3u .mid .webm .mkv .asf
.mpg .mpeg .mp10 .mpg10 .mpeg13
.aif AND .aiff
.3gp AND .3gpp
.wma AND .wmv
bla.mp3 bla bla.mid.mp3.mp4.mid.mp10.mpeg.mpg.mpg10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}