using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+idIwant\\"":{\\""(.+?)\\.+";
string substitution = @"$1";
string input = @"{},\""employees\"":{},\""idIwant\"":{\""2545\"":{\""attributes\"":{\""offset\"":9855,";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}