import Foundation
let pattern = #".+idIwant\\":{\\"(.+?)\\.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{},\"employees\":{},\"idIwant\":{\"2545\":{\"attributes\":{\"offset\":9855,"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)