re = /.+idIwant\\":{\\"(.+?)\\.+/m
str = '{},\\"employees\\":{},\\"idIwant\\":{\\"2545\\":{\\"attributes\\":{\\"offset\\":9855,'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result