#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(?:\b[01]\d|2[0-3])[:∶][0-5]\d\b)"
Local $sString = "Received from SOMEONE 11/02/2020 13∶20 $ 997,63 $ 997,63 -" & @CRLF & _
"'Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -" & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)