import re
regex = re.compile(r"(?=(?:\b[01]\d|2[0-3])[:∶][0-5]\d\b)", flags=re.MULTILINE)
test_str = ("Received from SOMEONE 11/02/2020 13∶20 $ 997,63 $ 997,63 -\n"
"'Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -\n")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)