const regex = new RegExp('(?=(?:\\b[01]\\d|2[0-3])[:∶][0-5]\\d\\b)', 'gm')
const str = `Received from SOMEONE 11/02/2020 13∶20 \$ 997,63 \$ 997,63 -
'Received from SOMEONE 11/02/2020 13:20 \$ 997,63 \$ 997,63 -
`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);