import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:\\b[01]\\d|2[0-3])[:∶][0-5]\\d\\b)";
final String string = "Received from SOMEONE 11/02/2020 13∶20 $ 997,63 $ 997,63 -\n"
+ "'Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}