use strict;
my $str = 'Received from SOMEONE 11/02/2020 13∶20 $ 997,63 $ 997,63 -
\'Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -
';
my $regex = qr/(?=(?:\b[01]\d|2[0-3])[:∶][0-5]\d\b)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";