# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[^\W0]\w{3,14})\w(?=\w{4})/*/gm;t' <<< "0001113033AA55608981 → 0001113*********8981
23456237472347823923 → 2345************3923
00000000090000000000 → 0000000009000***0000
09008000800060050000 → 09008***********0000
AAAABBBBCCCCDDDDEEEE → AAAA************EEEE
0000BBBBCCCCDDDDEEEE → 0000BBBB********EEEE"