#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[^\W0]\w{3,14})\w(?=\w{4})"
Local $sString = "0001113033AA55608981 → 0001113*********8981" & @CRLF & _
"23456237472347823923 → 2345************3923" & @CRLF & _
"00000000090000000000 → 0000000009000***0000" & @CRLF & _
"09008000800060050000 → 09008***********0000" & @CRLF & _
"AAAABBBBCCCCDDDDEEEE → AAAA************EEEE" & @CRLF & _
"0000BBBBCCCCDDDDEEEE → 0000BBBB********EEEE"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)