import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^\\W0]\\w{3,14})\\w(?=\\w{4})";
final String string = "0001113033AA55608981 → 0001113*********8981\n"
+ "23456237472347823923 → 2345************3923\n"
+ "00000000090000000000 → 0000000009000***0000\n"
+ "09008000800060050000 → 09008***********0000\n"
+ "AAAABBBBCCCCDDDDEEEE → AAAA************EEEE\n"
+ "0000BBBBCCCCDDDDEEEE → 0000BBBB********EEEE";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}