import re
regex = re.compile(r"(?<=[^\W0]\w{3,14})\w(?=\w{4})", flags=re.MULTILINE)
test_str = ("0001113033AA55608981 → 0001113*********8981\n"
"23456237472347823923 → 2345************3923\n"
"00000000090000000000 → 0000000009000***0000\n"
"09008000800060050000 → 09008***********0000\n"
"AAAABBBBCCCCDDDDEEEE → AAAA************EEEE\n"
"0000BBBBCCCCDDDDEEEE → 0000BBBB********EEEE")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)