using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^\W0]\w{3,14})\w(?=\w{4})";
string substitution = @"*";
string input = @"0001113033AA55608981 → 0001113*********8981
23456237472347823923 → 2345************3923
00000000090000000000 → 0000000009000***0000
09008000800060050000 → 09008***********0000
AAAABBBBCCCCDDDDEEEE → AAAA************EEEE
0000BBBBCCCCDDDDEEEE → 0000BBBB********EEEE";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}