using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @", *[A-Z]+\b";
string substitution = @"";
string input = @"Smith, SMITH, John, JOHN";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}