import re
regex = re.compile(r", *[A-Z]+\b", flags=re.MULTILINE)
test_str = "Smith, SMITH, John, JOHN"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)