$re = '/, *[A-Z]+\b/m';
$str = 'Smith, SMITH, John, JOHN';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;