package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m), *[A-Z]+\b`)
var str = `Smith, SMITH, John, JOHN`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}