const regex = /, *[A-Z]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(', *[A-Z]+\\b', 'gm')
const str = `Smith, SMITH, John, JOHN`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);