#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(feat|fix|perf|refactor|removed)(:\s)(HPA-\d+)(\s)(.+)"
Local $sString = "feat: HPA-1234 Test" & @CRLF & _
"fix: HPA-1234321 Test" & @CRLF & _
"perf: HPA-1234 Тест 123 Test" & @CRLF & _
"refactor: HPA-1234 Тест" & @CRLF & _
"removed: HPA-1234 Test "тест" 123" & @CRLF & _
"ffeat: HPA-1234 Test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")