using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(feat|fix|perf|refactor|removed)(:\s)(HPA-\d+)(\s)(.+)";
string input = @"feat: HPA-1234 Test
fix: HPA-1234321 Test
perf: HPA-1234 Тест 123 Test
refactor: HPA-1234 Тест
removed: HPA-1234 Test ""тест"" 123
ffeat: HPA-1234 Test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}