use strict;
my $str = 'feat: HPA-1234 Test
fix: HPA-1234321 Test
perf: HPA-1234 Тест 123 Test
refactor: HPA-1234 Тест
removed: HPA-1234 Test "тест" 123
ffeat: HPA-1234 Test';
my $regex = qr/^(feat|fix|perf|refactor|removed)(:\s)(HPA-\d+)(\s)(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}