$re = '/^(feat|fix|perf|refactor|removed)(:\s)(HPA-\d+)(\s)(.+)/m';
$str = 'feat: HPA-1234 Test
fix: HPA-1234321 Test
perf: HPA-1234 Тест 123 Test
refactor: HPA-1234 Тест
removed: HPA-1234 Test "тест" 123
ffeat: HPA-1234 Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);