const regex = /^(feat|fix|perf|refactor|removed)(:\s)(HPA-\d+)(\s)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(feat|fix|perf|refactor|removed)(:\\s)(HPA-\\d+)(\\s)(.+)', 'gm')
const str = `feat: HPA-1234 Test
fix: HPA-1234321 Test
perf: HPA-1234 Тест 123 Test
refactor: HPA-1234 Тест
removed: HPA-1234 Test "тест" 123
ffeat: HPA-1234 Test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}