import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span style=\\\"font-size:14px;\\\">([\\w\\s]+)(<\\/span>)";
final String string = "<div class=\"Description_Productinfo\" itemprop=\"description\"><p><span style=\"color:#7f8c8d;\"><span style=\"font-family:Arial,Helvetica,sans-serif;\"><span style=\"font-size:14px;\">Alphanumeric Words If You Wish To Match</span></span></span></p></div>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}