const regex = /<span style=\"font-size:14px;\">([\w\s]+)(<\/span>)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span style=\\"font-size:14px;\\">([\\w\\s]+)(<\\\/span>)', 's')
const str = `<div class="Description_Productinfo" itemprop="description"><p><span style="color:#7f8c8d;"><span style="font-family:Arial,Helvetica,sans-serif;"><span style="font-size:14px;">Alphanumeric Words If You Wish To Match</span></span></span></p></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}