// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<span style=\"font-size:14px;\">([\w\s]+)(<\/span>)"#).unwrap();
let string = "<div class=\"Description_Productinfo\" itemprop=\"description\"><p><span style=\"color:#7f8c8d;\"><span style=\"font-family:Arial,Helvetica,sans-serif;\"><span style=\"font-size:14px;\">Alphanumeric Words If You Wish To Match</span></span></span></p></div>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}