re = /<span style=\"font-size:14px;\">([\w\s]+)(<\/span>)/
str = '<div class="Description_Productinfo" itemprop="description"><p><span style="color:#7f8c8d;"><span style="font-family:Arial,Helvetica,sans-serif;"><span style="font-size:14px;">Alphanumeric Words If You Wish To Match</span></span></span></p></div>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end