#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^Time_in_seconds\[\d+\]Time_in_seconds$(\R?))+"
Local $sString = "Time_in_seconds[1]Time_in_seconds" & @CRLF & _
"Time_in_seconds[123]Time_in_seconds" & @CRLF & _
"Time_in_seconds[*]Time_in_seconds" & @CRLF & _
"" & @CRLF & _
"Time_in_seconds[1]Time_in_seconds" & @CRLF & _
"Time_in_seconds[2]Time_in_seconds" & @CRLF & _
"Time_in_seconds[3]Time_in_seconds"
Local $sSubst = "My new line$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)