const regex = /(?:^Time_in_seconds\[\d+\]Time_in_seconds$(\R?))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^Time_in_seconds\\[\\d+\\]Time_in_seconds$(\\R?))+', 'gm')
const str = `Time_in_seconds[1]Time_in_seconds
Time_in_seconds[123]Time_in_seconds
Time_in_seconds[*]Time_in_seconds
Time_in_seconds[1]Time_in_seconds
Time_in_seconds[2]Time_in_seconds
Time_in_seconds[3]Time_in_seconds`;
const subst = `My new line$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);