// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^Time_in_seconds\[\d+\]Time_in_seconds$(\R?))+").unwrap();
let string = "Time_in_seconds[1]Time_in_seconds
Time_in_seconds[123]Time_in_seconds
Time_in_seconds[*]Time_in_seconds
Time_in_seconds[1]Time_in_seconds
Time_in_seconds[2]Time_in_seconds
Time_in_seconds[3]Time_in_seconds";
let substitution = "My new line$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}