import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^Time_in_seconds\\[\\d+\\]Time_in_seconds$(\\R?))+";
final String string = "Time_in_seconds[1]Time_in_seconds\n"
+ "Time_in_seconds[123]Time_in_seconds\n"
+ "Time_in_seconds[*]Time_in_seconds\n\n"
+ "Time_in_seconds[1]Time_in_seconds\n"
+ "Time_in_seconds[2]Time_in_seconds\n"
+ "Time_in_seconds[3]Time_in_seconds";
final String subst = "My new line$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}