re = /(?:^Time_in_seconds\[\d+\]Time_in_seconds$(\R?))+/m
str = 'Time_in_seconds[1]Time_in_seconds
Time_in_seconds[123]Time_in_seconds
Time_in_seconds[*]Time_in_seconds
Time_in_seconds[1]Time_in_seconds
Time_in_seconds[2]Time_in_seconds
Time_in_seconds[3]Time_in_seconds'
subst = 'My new line$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result