# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^(<abc>)|\G(?!^))([^\s<]+)[ \t]*/$1$2/gm;t' <<< "<abc>this is between abc</abc><efg>this is between efg</efg>
<abc>this is between abc</abc><efg>this is between efg</efg>"