$re = '/(?:^(<abc>)|\G(?!^))([^\s<]+)[ \t]*/m';
$str = '<abc>this is between abc</abc><efg>this is between efg</efg>
<abc>this is between abc</abc><efg>this is between efg</efg>';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;