re = /(?:^(<abc>)|\G(?!^))([^\s<]+)[ \t]*/m
str = '<abc>this is between abc</abc><efg>this is between efg</efg>
<abc>this is between abc</abc><efg>this is between efg</efg>'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result