import Foundation
let pattern = #"(?:^(<abc>)|\G(?!^))([^\s<]+)[ \t]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<abc>this is between abc</abc><efg>this is between efg</efg>
<abc>this is between abc</abc><efg>this is between efg</efg>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)