import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(<abc>)|\\G(?!^))([^\\s<]+)[ \\t]*";
final String string = "<abc>this is between abc</abc><efg>this is between efg</efg>\n"
+ "<abc>this is between abc</abc><efg>this is between efg</efg>";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}