using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(<abc>)|\G(?!^))([^\s<]+)[ \t]*";
string substitution = @"$1$2";
string input = @"<abc>this is between abc</abc><efg>this is between efg</efg>
<abc>this is between abc</abc><efg>this is between efg</efg>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}