#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?<=texta |textb )[1-9]\d{0,3})|(?:[1-9]\d{0,3}(?= textc| textd))"
Local $sString = "texta 4987" & @CRLF & _
"textb 4328" & @CRLF & _
"3987 textc" & @CRLF & _
"4382 textd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")