re = /(?:(?<=texta |textb )[1-9]\d{0,3})|(?:[1-9]\d{0,3}(?= textc| textd))/
str = 'texta 4987
textb 4328
3987 textc
4382 textd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end