import Foundation
let pattern = #"(?:(?<=texta |textb )[1-9]\d{0,3})|(?:[1-9]\d{0,3}(?= textc| textd))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
texta 4987
textb 4328
3987 textc
4382 textd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)