using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=texta |textb )[1-9]\d{0,3})|(?:[1-9]\d{0,3}(?= textc| textd))";
string input = @"texta 4987
textb 4328
3987 textc
4382 textd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}