import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=texta |textb )[1-9]\\d{0,3})|(?:[1-9]\\d{0,3}(?= textc| textd))";
final String string = "texta 4987\n"
+ "textb 4328\n"
+ "3987 textc\n"
+ "4382 textd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}