const regex = /(?:(?<=texta |textb )[1-9]\d{0,3})|(?:[1-9]\d{0,3}(?= textc| textd))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=texta |textb )[1-9]\\d{0,3})|(?:[1-9]\\d{0,3}(?= textc| textd))', 'g')
const str = `texta 4987
textb 4328
3987 textc
4382 textd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}