# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+(?=[0-9]{2}\.[0-9]{4})/\n/gm;t' <<< "24.3483 stuff stuff 34.8325 some more stuff"