using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?=[0-9]{2}\.[0-9]{4})";
string substitution = @"\n";
string input = @"24.3483 stuff stuff 34.8325 some more stuff";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}