use strict;
my $str = '24.3483 stuff stuff 34.8325 some more stuff';
my $regex = qr/\s+(?=[0-9]{2}\.[0-9]{4})/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";