const regex = /\s+(?=[0-9]{2}\.[0-9]{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(?=[0-9]{2}\\.[0-9]{4})', 'gm')
const str = `24.3483 stuff stuff 34.8325 some more stuff`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);